What to Do When Chrome Wants to Update — but Can’t

Q. I get a message when I open Chrome and use Gmail or Facebook every day that says that my Chrome version is out of date and that I need to upgrade. When I go to Chrome to check the version, it says I have the latest one. Why do I keep getting these messages?

Photo

You can check your version and get help with updating Google Chrome in the browser’s settings.

Credit
The New York Times

A. Update hiccups with Google Chrome can happen for a number of reasons, but start by checking that your computer’s operating system meets the requirements for the latest version of the browser. For the current version of Chrome, you need at least Windows 7, Mac OS X 10.9 (Mavericks) or 64-bit editions of the major Linux distributions (like Ubuntu, Debian, openSUSE or Fedora) that were released in the past few years.

If your operating system is outdated, Chrome may have moved on without it. Windows users should check the browser’s Properties box to make sure the program isn’t set to run in compatibility mode for an earlier version of the system. Those using Chrome on an office network may be at the mercy of the corporate I.T. department as to when updates can actually be installed on company computers. Firewall settings and other security software could also prevent Chrome from updating properly.

Adware or malware may be another source of the problem, with variations of the “Urgent Chrome Update” pop-up plaguing some users as it tries to hijack the browser. Scanning your system with antivirus and antimalware software may root out the source of the messages.

If none of these issues seems to be causing the problem, uninstalling the browser and reinstalling it with a fresh copy might take care of the situation. You can get the latest version of Google Chrome at www.google.com/chrome. Be sure to restart after you install the software.

Continue reading the main story

Read the full article from the Source…

Leave a Reply

Your email address will not be published. Required fields are marked *